Limited availability for the Amazon API in the North American market.
Resolved
Amazon has informed that this issue has been solved and the data is populating again as usual. Thank you for your patience.
Posted Dec 08, 2020 - 10:12 CET
Identified
Amazon is reporting limited availability for their API in the North American market. This may result in a delay to update reports in Sellics and inability to make changes on campaigns through Sellics in the North American market. The Amazon team of engineers is already working on a solution and hope to have the issue resolved soon.

We will update you on any developments on the matter.

Best regards,
Your Sellics Team
Posted Dec 03, 2020 - 11:01 CET
This incident affected: Tool overall.