Not possible to access Advertising Edition at the moment
Resolved
The system is available again. We apologize for the circumstances and thank you for your patience.
Posted Dec 04, 2020 - 10:58 CET
Identified
We are experiencing issues with the login to the Advertising Edition at the moment. Our team is already working on this issue and we will inform you here as soon as the access is available again.
Posted Dec 04, 2020 - 10:38 CET
This incident affected: Tool overall.